Synology DiskStation Manager nicht erreichbar

Standard

Seit einigen Jahren setze ich auf die DiskStation-Produkte von Synology und bin immer wieder begeistert von den vielfältigen Möglichkeiten dieser „Miniserver“. Es fing damals mit einer DS107+ an, gefolgt von einer DS111. Seit Ende letzten Jahres setze ich eine DS214+ ein, bestückt mit einer 2TB Festplatte. Nachdem mir die 1-Bay-Modelle im Prinzip immer zu wenig erweiterbar und flexibel waren, habe ich mich beim letzten Mal bewusst für ein 2-Bay-Modell entschieden. Zur Zeit nutze ich nur einen Schacht, den zweiten möchte ich mir für eine evtl. bald notwendige Erweiterung meiner Kapazitäten vorbehalten. Als RAID-Modus habe ich SHR gewählt, um möglichst flexibel auf meine Anforderungen reagieren zu können. Gesichert wird im monatlichen Rhythmus auf eine externe USB-Festplatte.

Softwareseitig bin ich eigentlich bisher immer ganz gut damit gefahren, die jeweils neueste Version des DiskStation Managers (DSM) zu installieren. Das eher rumpelige 5.1 Update hatte bisher an meiner DiskStation klaglos funktioniert. Ein relativ „harmloses“ Minor-Update brachte jedoch die Offenbarung: Am 13.01.2015 stand das Update 5.1-5022 in meinem DSM zum Update bereit, nach kurzem Ansehen des eher kurzen Changelogs installierte ich dieses und bemerkte zunächst einmal keinen Unterschied. Meistens greife ich per SMB oder SFTP auf die DiskStation zu, was weiterhin problemlos funktionierte. Nachdem ich ein paar Tage nicht mehr in die Weboberfläche des DSM hineingesehen hatte, wollte ich mich am 21.1. routinemässig am DSM anmelden – das Aufrufen des bei mir standardmässig auf https umgeleitete DSM-Portals (https://<DiskstationURL>:5001) endete in einer weissen Seite ohne jede Fehlermeldung. Ein Aufrufen des DSM zuerst von einem anderen Browser, dann von einem anderen PC im Netz aus, brachte ebenfalls nur die weisse Seite. Die DiskStation war jedoch weiterhin per SMB Share erreichbar, und reagierte auch auf auf Ping. Der Synology-Assistant fand die DiskStation ebenfalls unter der gewohnten festen IP-Adresse mit dem Status „fertig“. Und der Clou: Auch die PhotoStation sowie BitTorrent Sync Interface waren wie gewohnt erreichbar! Es funktionierte also wirklich nur das DSM nicht, was die Suche schon einigermassen einschränkte. Zum Glück habe ich bei der DiskStation generell SSH aktiviert (generell sehr zu empfehlen!!!), was mir ebenfalls ermöglichte, per Terminal auf die DS zuzugreifen.

Nach einiger Sucherei in der allwissenden Müllhalde kam mir die Idee, dass es evtl. damit zu tun haben könnte, dass ich mein DSM so konfiguriert habe, dass es standarmässig nur per https erreichbar ist, und dazu jede Anfrage an den Default-Port 5000 an den https-Port 5001 umleitet. Da dies wohl schon beim Update von 5.0 auf 5.1 zu Problemen, insbesondere in Zusammenhang mit installierten Drittanbieter-Paketen, geführt haben soll, vermutete ich einen Zusammenhang. Eine Lösung, um die Port-Weiterleitung 5000 auf 5001 per SSH rückgängig zu machen, war schnell gefunden. Die Schritte, die mir in dem Fall viel Arbeit erspart haben, hier einmal kurz für die Nachwelt notiert:

  1. per SSH als root an der Diskstation anmelden (unter Windows benutzt man dafür am besten PuTTY, am Mac/Linux das normale Terminal)
  2. vi /etc/synoinfo.conf (öffnet den vi Editor mit der Datei „/etc/synoinfo.conf“)
  3. „/“ drücken und „runHTTPS“ (jeweils ohne Anführungszeichen) eingeben, die Suche sollte auf eine Zeile springen, die normalerweise „runHTTPS=“yes““ lautet.
  4. „i“ drücken.
  5. Den Wert „runHTTPS=“yes““ auf „no“ ändern.
  6. ESC Taste drücken.
  7. :wq (dies speichert und beendet den vi Editor)
  8. /usr/syno/etc/rc.d/S97apache-sys.sh restart (hiermit wird der DSM-Dienst neu gestartet)
  9. Anschliessend sollte man sich wieder per „http://<DiskStationHostname>:5000“ am DSM anmelden können.

Damit konnte ich mich nun also wieder am DiskStation Manager anmelden. Im Benachrichtigungscenter empfing mich jedoch folgende Fehlermeldung:

DSM Benachrichtigungen

„DSM kann nicht normal starten, da er auf ein Problem gestoßen ist. Bitte kontaktieren Sie den Synology Kundendienst, um Hilfe zu erhalten.“
Ja, nur schön, dass man diese Meldung erst erhält, wenn man das Gerät wieder am Laufen hat. Eine Mail-Benachrichtigung (die zwar konfiguriert ist, aber in diesem Fall offenbar versagt hat?) wäre hier sinnvoller.

Ein Blick in die Systemsteuerung „Netzwerk“ auf den Tab „DSM-Einstellungen“ bestätigte, dass die automatische https-Umleitung derzeit nicht aktiv war. Ich wollte allerdings dem Problem auf den Grund gehen, und aktivierte den Haken „HTTPS-Verbindung aktivieren“ – jedoch dieses Mal OHNE die automatische Umleitung direkt darunter, um mich nicht wieder auszusperren (siehe Screenshot):

 

DSM-Einstellungen

Ein anschliessender Versuch bestätigte, dass ich wiederum problemlos per http und Port 5000, jedoch nicht über https mit Port 5001 auf die DiskStation kam.

Das restliche Verfahren habe ich dann nur noch aus „Erfahrungswerten“ zusammengeklickt. Ich ging ins Paket-Zentrum und deaktivierte hier kurzerhand ALLE Pakete (CloudStation, BitTorrent Sync, Medienserver usw. usf.). Anschliessend rebootete ich die DiskStation, testete den https-Zugriff – welcher nun endlich funktionierte! Anschliessend aktivierte ich die benötigten Pakete nach und nach wieder, unter ständiger Stichprobe des https-Zugriffs. Das Ende vom Lied? Nachdem ich alle Pakete wieder aktiviert, und die DiskStation nochmals in dieser Konfiguration rebootet hatte, blieb der https-Zugriff nun funktionsfähig. Juhu!

Ich hoffe, dem einen oder anderen von euch mit dieser kleinen Anleitung geholfen und möglicherweise ein aufwändiges Neuinstallieren der DSM Software (wenn man viel konfiguriert hat, so wie ich), oder gar Datenverlust erspart zu haben. Ganz wichtige Lektion, die ich (wieder einmal) gelernt habe: Unbedingt den SSH-Zugriff aktivieren, ohne diesen hätte ich in dem Fall wohl ganz schön alt ausgesehen! Die DiskStation ist eben auch „nur“ ein Linux-Server, was gerade in solchen Situationen ein echter Vorteil ist.

Ich geh jetzt mein Backup machen.